Add tig from git.
[rentiernetz-overlay.git] / dev-vcs / tig / tig-9999.ebuild
1 EAPI=5
2
3 inherit git-r3 bash-completion-r1 toolchain-funcs autotools
4
5 DESCRIPTION="Tig: text mode interface for git"
6 HOMEPAGE="http://jonas.nitro.dk/tig/"
7 EGIT_REPO_URI="https://github.com/jonas/tig.git"
8
9 LICENSE="GPL-2"
10 SLOT="0"
11 KEYWORDS=""
12 IUSE="unicode doc"
13
14 DEPEND="sys-libs/ncurses[unicode?]
15         sys-libs/readline:0
16         doc? ( app-text/asciidoc app-text/xmlto )"
17 RDEPEND="${DEPEND}
18         dev-vcs/git"
19
20 src_prepare() {
21         eautoreconf
22 }
23
24 src_configure() {
25         econf $(use_with unicode ncursesw)
26 }
27
28 src_compile() {
29         emake
30 }
31
32 src_install() {
33         emake DESTDIR="${D}" install
34
35         if use doc; then
36                 emake DESTDIR="${D}" install-doc-man install-doc-html
37         fi
38
39         newbashcomp contrib/tig-completion.bash ${PN}
40 }